Questions about SaxoWebTrader

What are the system requirements for SaxoWebTrader?

SAXOWEBTRADER SUPPORT ON PCs

The SaxoWebTrader platform is officially supported in the following browsers on PCs:

  • Internet Explorer 7 or newer
  • Firefox 8 or newer
  • Google Chrome 17 or newer
Important: Microsoft .Net Framework 4.0 or above must be installed in order to view Advanced Charts.
 
SAXOWEBTRADER SUPPORT ON APPLE MACs
 
The SaxoWebTrader platform is officially supported in the following browsers on Apple Macs:
  • Safari 4 or newer
  • Firefox 8 or newer
  • Google Chrome 17 or newer
Important: Microsoft .Net Framework 4.0 or above must be installed in order to view Advanced Charts. It is not currently available on Apple Mac.